Hugo Advance Docs

Install Hugo

To use this theme you will need to have Hugo installed. If you don’t already have Hugo installed please follow the official installation guide

Check Hugo Version (Hugo 0.80+ Extended is Required)

This theme uses Hugo Pipes to compile SCSS and minify assets. Please make sure you have the Hugo Extended version installed. If you are not using the extended version this theme will not not compile.

To check your version of Hugo, run:

hugo version

This will output the currently installed version of Hugo. Make sure you see /extended after the version number.

Hugo Static Site Generator v0.80/extended darwin/amd64 BuildDate: unknown

Note: You do not need to use version v0.80 specifically, you can use any version of Hugo above 0.80 (even some older versions will work). It just needs to have the /extended part